Christophe Casalegno

Continuer d’utiliser let’s encrypt sur des serveurs debian obsolètes wheezy & sid (7 et 8)

Bonjour les amis, j’espère que vous allez bien. Si vous maintenez encore du parc « Legacy » (oui je sais, c’est mal : mais si vous êtes du métier, vous savez que certaines contraintes sont imposées par les clients : on peut les accepter, ou non (et dans ce cas voir partir ce dernier) et que vous utilisez certbot-auto pour continuer à mettre à jour vos certificats SSL let’s encrypt, vous avez sans doute constaté depuis quelques temps que cela ne fonctionne plus, et apparemment l’outil a même été retiré de son emplacement original.

Pour autant il est toujours possible de faire fonctionner ce dernier. En mars ou avril 2019, j’ai été confronté à ce problème pour un client qui tournait encore sous debian 7 (wheezy) et qui était confronté à un soucis similaire. J’avais pour l’occasion patché la version de certbot-auto du moment pour lui permettre de continuer de bénéficier des certificats let’s encrypt.

Il y a peu, après de nouveaux changements au niveau des versions supportées d’ACME, j’ai été confronté à la même chose avec des serveurs encore en debian 8 (sid). Me souvenant encore du nom du client pour qui j’avais patché certbot-auto pour la version 7, je suis aller récupérer le fichier et là… miracle, il fonctionne également sur debian 8. Du coup j’ai décidé de vous en faire profiter. Enjoy!

Vous pouvez le retrouver via la rubrique contribution ou directement via le lien suivant : certbot-auto.

N’oubliez pas d’utiliser l’option –no-self-upgrade 😉 Bonne fin de week-end à toutes et à tous.

Christophe Casalegno
​Vous pouvez me suivre sur : Twitter | Facebook | Linkedin | Telegram | Youtube

11 Commentaires

  1. Super, merci beaucoup pour le travail et le partage !

  2. Bonjour,

    merci du tuyau mais sur Debian 8 ca marche pas cela me dit

    Your system is not supported by certbot-auto anymore.
    certbot-auto and its Certbot installation will no longer receive updates.
    You will not receive any bug fixes including those fixing server compatibility
    or security problems.
    Please visit https://certbot.eff.org/ to check for other alternatives.
    An unexpected error occurred:
    CalledProcessError: Command ‘(‘lsb_release’, ‘-a’)’ returned non-zero exit status 1

  3. C’est top, ça fonctionne !!!
    Merci beaucoup….

  4. Bonjour, est-ce que ce patch fonctionne toujours ? Su oui comment faut-il l’installer ? Juste en remplaçant l’ancien certbot-auto ?
    D’avance merci pour votre temps

    • Bonjour Greg, oui ce patch fonctionne toujours. Il suffit en effet de remplacer certbot-auto, attention également comme indiqué dans le post à bien bloquer les mises à jour automatiques lors de son utilisation.

  5. bonjour,
    cela fonctionne encore?

Répondre à xposer Annuler la réponse

Votre adresse e-mail ne sera pas publiée.